Jump to content
  • 0
albert cruz

Black Screen

Question

Hello guys, i encounter this "Black Screen" after i compile my zip file to cocoon. Before i post this topic, i googled a lot and luckily ive seen some thread from cocoon forum that this problem have been fixed by:

 

1. Custom Loader

2. Box 2d web(Physics)

3. uncheck minify

4. Include c2 cocoon plugin to cocoon.io plugin

 

I have tried everything but still i got a black screen. Currently using version 240 of construct2

Share this post


Link to post

5 answers to this question

Recommended Posts

  • 0

I finally fixed it but only by using webview+ and im not happy with the performance of the game. It lags/hang 1second everytime i tap on the object from my game.

Suggestions how to fix it or how to convert in canvas+ without black screen?

Share this post


Link to post
  • 0

Hi @albert cruz

You can create a Developer App from your Cocoon Project. Then run your Construct 2 exported files as .zip with this app. So you have access to the device error log. Please share a screenshot of the error.

Please find a link here.

https://shatter-box.com/knowledgebase/cocoonio/#debug

1) Login to your cocoon account and select your project

2) Scroll down till "Compile Developer App"

cio_developer_app.png

3) Download and install the Developer App.

cio_developer_app_download.png

 

This app has the same plugins installed and the same preferences (bundle id and so on) as your final build. So you can test all functions including Leaderboard and InApp with it.

Regards 

Andy

Share this post


Link to post
  • 0

Hi andy, it worked now. There is a bug (i dont know what to call it) on version r240 of construct. What i did was to downgrade the version of construct. At first i started from 224. It didnt worked, the black screen still appears and then i change the version again to r230 and it worked

 

But......

 

I am not happy with the performance. Everytime i touch anywhere on the game. It hangs/lags for 1 second plus when i click on the start button to go to the main game layout, it took for an about 10-15seconds

If i cant fix the performance, ill surely transfer to BUILDBOX :(

  • Like 1

Share this post


Link to post
  • 0
38 minutes ago, albert cruz said:

I am not happy with the performance. Everytime i touch anywhere on the game. It hangs/lags for 1 second plus when i click on the start button to go to the main game layout, it took for an about 10-15seconds

If i cant fix the performance, ill surely transfer to BUILDBOX :(

Hi @albert cruz

I'm glad that it worked now for you. I'm using version r239 and it works fine as well on my end. I can remember an issue with version r240 due to the new WebGL code. You can read more about it here.

https://forums.cocoon.io/t/conctruct-2-bug-cordova/4178/17?u=andy_reitberger

About the performance. You can do something to speed it up. Please see here

https://shatter-box.com/knowledgebase/troubleshooting-fixes/#slow-loading

But it also can be caused by your project (code or/and large images). I would be glad if you tried my game here.

https://play.google.com/store/apps/details?id=com.matchtrhee.shatter

It has the lazyload fix in.

Regards

Andy

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy, Terms of Use, We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. & Guidelines.