Jump to content
jose antonio dominguez

Problem with cocoonjs(openSSL)

Recommended Posts

Hi Andreas,I am a user of cocoonjs.I received this message from google play;

The vulnerabilities were fixed in OpenSSL versions beginning with 1.0.1h, 1.0.0m, and 0.9.8za. To confirm your OpenSSL version, you can do a grep via:

$ unzip -p YourApp.apk | strings | grep "OpenSSL"

For more information about the vulnerability, please see this OpenSSL Security Advisory. For other technical questions, please post toStack Overflow and use the tags "android-security" and "openssl."

wrote in forum Ludei,but I got no answer.I can not use cocoon.io,because I'm wrong and will not let me go up more projects.I like cocoonjs,It is very light(more than intel xdk).Thanks for your help,and sorry for my English.

Share this post


Link to post

Hi :)

the warning for an OpenSSL bug comes mostly from old and outdated compiler. Have you checked the latest compiler version at http://cloud.ludei.com ?

openSSL.png.1dd131d164eb51f04e127d643673

If the warning remains, you need to wait for the respone from ludei, because the issue is caused by an outdated code in the compiler.

I also know that an older version of Crosswalk has caused such an issue (https://shatter-box.com/knowledgebase/fix-openssl-issue/). But you said you are using cocoonJS, so I guess this is not the issue ;)

Hope this helps you ;)

Regards

Andreas

  • Like 1

Share this post


Link to post
On 27/11/2015 21:43:47, Andreas said:

Hi :)

the warning for an OpenSSL bug comes mostly from old and outdated compiler. Have you checked the latest compiler version at http://cloud.ludei.com ?

openSSL.png.1dd131d164eb51f04e127d643673

If the warning remains, you need to wait for the respone from ludei, because the issue is caused by an outdated code in the compiler.

I also know that an older version of Crosswalk has caused such an issue (https://shatter-box.com/knowledgebase/fix-openssl-issue/). But you said you are using cocoonJS, so I guess this is not the issue ;)

Hope this helps you ;)

Regards

Andreas

I have solved updating OpenSSL libraries

  • Like 1

Share this post


Link to post
2 minutes ago, jose antonio dominguez said:

Hi,Andreas,I have solved updating OpenSSL libraries,framerwork and VisualC++.thanks for everything,Will write the solution Ludei forum.

You're welcome :) This will help a lot of other people if you post it to ludei's forum!

Thank you for that!

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy, Terms of Use, We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. & Guidelines.